Skip to content

Tag: gradle-shadow-plugin

Multiple dependency versions with Gradle 5

I need to support 2 different versions of the same library (to support a legacy version), es4hadoop for Apache Spark. Version 6.2.2(https://mvnrepository.com/artifact/org.elasticsearch/elasticsearch-spark-13_2.10/6.2.2) Version 6.3.2 (https://mvnrepository.com/artifact/org.elasticsearch/elasticsearch-spark-13_2.10/6.3.2) Both versions have same dependencies (scala-lang and Spark). Not sure at all about the naming of that, but I would like something like: so I can use both new and old elasticsearch library, in the