Skip to content
Advertisement

Minimum Spring version compatible with Java 11

I need to upgrade an app to Java 11 very soon, I was wondering what’s the minimum Spring version that is compatible with Java 11.

I’m currently using Java 8 and Spring 4.2.7.

Advertisement

Answer

From their task tracker — SPR-16391:Compatibility with JDK 11. The compatibility of JDK 10, 11 is planned along with 5.1 GA release.

JDK 11 is currently scheduled for September 2018. Not expecting any major changes beyond JDK 10 from our perspective, we should be able to fully support it in the 5.1 line already.

Ideally our framework build would be able to run on JDK 8, 9, 10 as well as 11, even if our own test efforts will focus on JDK 8 and 11 (as the official long-term support branches) at that point.

While the option of experimenting with your own code on module path is still feasible using spring framework 5.0, which provides out-of-the-box support for JDK 9 already.

Update: Spring Framework 5.1 goes GA on 21st September, 2018

Advertisement