Compability JDBC driver versions and PostgreSQL versions



Can anyone point me on where to find an exact documenation which postgreSQL database version requires which JDBC driver version?

In the case at hand I want to know: What is the minimum required JDBC version in a Java server application connecting to a database of version PostgreSQL 11.13?

Unfortunately the PostgreSQL JDBC Driver website is not really precise on this:

The current version of the driver should be compatible with PostgreSQL
8.2 and higher, and Java 6 (JDBC 4.0), Java 7 (JDBC 4.1), Java 8 (JDBC 4.2) and Java 9.

https://jdbc.postgresql.org/about/about.html

Answer

The question is a wrong one. Why would you want to use a JDBC driver that has as many bugs as possible?

Rather, you want to ask what the oldest version is that the latest JDBC driver supports, and the documentation will tell you that

[…] nning old applications or JVMs), this is the driver you should be using. It supports PostgreSQL 8.2 or newer and requires Java 6 or newer.

Always use the latest JDBC driver, and you won’t go wrong.



Source: stackoverflow