Skip to content
Advertisement

What version of JPA am I using?

I’m using

    <dependency>
        <groupId>org.hibernate</groupId>
        <artifactId>hibernate-core</artifactId>
        <version>5.1.0.Final</version>
    </dependency>
    <dependency>
        <groupId>org.hibernate</groupId>
        <artifactId>hibernate-entitymanager</artifactId>
        <version>5.1.0.Final</version>
    </dependency>
    <dependency>
        <groupId>org.hibernate</groupId>
        <artifactId>hibernate-jpamodelgen</artifactId>
        <version>5.1.0.Final</version>
    </dependency>

in a apache-tomcat-8.0.41 web service.

In this link they say “Hibernate EntityManager implements the programming interfaces and lifecycle rules as defined by the JPA 2.0 specification” https://docs.jboss.org/hibernate/entitymanager/3.6/reference/en/html_single/

But it’s for the 3.6 version. It’s the same for 5.1 ?

Advertisement

Answer

I suggest you read the docs of the version you are using. As for hibernate and JPA compatibility see here: Hibernate releases

Hibernate 5.1 docs: Hibernate 5.1 docs

Advertisement