Skip to content

Cmd Prompt not detecting keyboard input

I originally posted this question on TechNet, but thought StackOverflow would be better!
http://social.technet.microsoft.com/Forums/en-US/d0eee59e-3a40-4502-a896-d818758e6c45/cmd-prompt-not-accepting-or-isnt-detecting-my-keyboard-input

I have a fairly odd problem, one I’ve never encountered before. Actually, I’m not sure that anyone has ever encountered this problem before. Googling doesn’t seem to turn up anything useful, but hopefully someone here can shed some light.

I’m trying to create a key store for signing an android app for the android market place. I’ve been following the instructions found here: http://www.thomasmortensen.com/index.php/71-android-keystore-jdk

I’ve found the same instructions on other websites too and as far I can tell I’m following them correctly.

This brings me to my problem: As I begin executing the “-keygen” command it seems to work fine and I am presented with the first field I need to supply to create the keystore – the keystore Password. However as I begin to type I notice that none of my input is being reflected i.e. I don’t see any * or any other text.

As far as I can tell, at this point the only input it accepts is the enter key. If I hit enter and leave the value blank it eventually quits the command, getting me back to square 1.

My keyboard is in perfect working order and I’m very sure that I’m entering in all the relevant fields correctly up until that point, so I was thinking it something to do with Cmd Prompt… could it be?

Shortly after I tried on my PC (Windows 7 Ultimate), I tried to do this on another 2 computers, one running windows 8 (Pro) and the other windows 7 (Ultimate) and both result in the same outcome…

Makes me think this isn’t something to do with Cmd Prompt!? :

Has anyone encountered this before?

Answer

Ok, so, a short while I ago I found a way “around” the problem which I think is worth sharing.
Hopefully the next person to run into this problem will be saved a whole lot of pain!

Basically, input is in fact being received by the command prompt at the keystore password step, though, instead of displaying an asterisk or some other placeholder the command prompt simply remains blank at this point.

The input is being entered, just not reflected on screen. This makes it harder to be sure you’ve entered the correct input, but if you’re very careful and have entered and confirmed the password values you will be able to successfully continue to the next step in the keygen process.

The next steps then continue to work as one would normally expect them to.

I still have no idea why the password step behaves so unexpectedly. If anyone has any insights I would be interested in hearing them.