Skip to content
Advertisement

Cannot resolve org.springframework.boot:spring-boot-autoconfigure:2.6.1 springboot | dubbo

When I used maven to import the jar package of dubbo-spring-boot-start, the following error occurred:

[INFO] Validation error:

[ERROR] org.eclipse.aether.resolution.ArtifactDescriptorException: Failed to read artifact descriptor for org.apache.dubbo:dubbo-spring-boot-starter:jar:2.7.3
[ERROR] Maven server structure problem

[ERROR] org.eclipse.aether.resolution.ArtifactDescriptorException: Failed to read artifact descriptor for org.apache.dubbo:dubbo-spring-boot-starter:jar:2.7.3
Cannot resolve org.springframework.boot:spring-boot-autoconfigure:2.6.1
Cannot resolve jakarta.annotation:jakarta.annotation-api:1.3.5
Cannot resolve jline:jline:0.9.94
Cannot resolve org.springframework:spring-core:5.3.13
Cannot resolve org.ow2.asm:asm:9.1
Cannot resolve org.apache.curator:curator-client:2.12.0
Cannot resolve jakarta.xml.bind:jakarta.xml.bind-api:2.3.3
Cannot resolve org.apache.logging.log4j:log4j-to-slf4j:2.14.1
Cannot resolve org.springframework:spring-test:5.3.13
Cannot resolve org.junit.jupiter:junit-jupiter-api:5.8.1
Cannot resolve org.slf4j:slf4j-api:1.7.32
Cannot resolve org.opentest4j:opentest4j:1.2.0
Cannot resolve org.springframework.boot:spring-boot-test:2.6.1
Cannot resolve net.minidev:accessors-smart:2.4.7



Springboot 2.6.1 and the dubbo-spring-boot-starter version is 2.7.3

Here is my pom.xml:

<?xml version="1.0" encoding="UTF-8"?>
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
         xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 https://maven.apache.org/xsd/maven-4.0.0.xsd">
    <modelVersion>4.0.0</modelVersion>
    <parent>
        <groupId>org.springframework.boot</groupId>
        <artifactId>spring-boot-starter-parent</artifactId>
        <version>2.6.1</version>
        <relativePath/> <!-- lookup parent from repository -->
    </parent>
    <groupId>com.kuang</groupId>
    <artifactId>springboot-11-provider-server</artifactId>
    <version>0.0.1-SNAPSHOT</version>
    <name>springboot-11-provider-server</name>
    <description>springboot-11-provider-server</description>
    <properties>
        <java.version>1.8</java.version>
    </properties>
    <dependencies>

        <dependency>
            <groupId>org.apache.dubbo</groupId>
            <artifactId>dubbo-spring-boot-starter</artifactId>
            <version>2.7.3</version>
        </dependency>

        <dependency>
            <groupId>com.github.sgroschupf</groupId>
            <artifactId>zkclient</artifactId>
            <version>0.1</version>
        </dependency>
        <dependency>
            <groupId>org.springframework.boot</groupId>
            <artifactId>spring-boot-starter-web</artifactId>
        </dependency>

        <dependency>
            <groupId>org.springframework.boot</groupId>
            <artifactId>spring-boot-starter-test</artifactId>
            <scope>test</scope>
        </dependency>
    </dependencies>

    <build>
        <plugins>
            <plugin>
                <groupId>org.springframework.boot</groupId>
                <artifactId>spring-boot-maven-plugin</artifactId>
            </plugin>
        </plugins>
    </build>

</project>


What’s the reason? When I add the dubbo-spring-boot-starter jar package, I get an error, but it can run when I downgrade to 2.7.0

Answer

Delete the .m2 folder then try again, I just experienced this.

Advertisement